Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 3
Ir a la página 1, 2, 3  Siguiente
 
Instalacion De Gambas 3.8.4 En Debian 8.3 Testing
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Instalacion De Gambas 3.8.4 En Debian 8.3 Testing 
 
Hola a todos.

Luego de una larga espera finalmente esta aquí la versión 3.8.4 de gambas para debian, claro que para instalarla habrá que hacer pining

Muchas gracias.
 



 
última edición por tincho el Lunes, 22 Febrero 2016, 00:37; editado 3 veces 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.7.1 En Debian 8 
 
Bueno, he descargado el código fuente desde sourceforge

sigo los pasos del wiki pero me salen estos warnings y no funciona la instalación, caba decir que la instle una segunda vez con la salida a

configure: WARNING: Unable to find file: libintl.so
configure: WARNING: This library may be located inside the system C library
configure: WARNING: Unable to find file: libiconv.so
configure: WARNING: This library may be located inside the system C library
ln: fallo al crear el enlace simbólico «/usr/bin/gbh3»: El fichero ya existe
configure: WARNING: Unable to find file: postgres.h
configure: WARNING: Unable to find file: pg_type.h
configure: WARNING: gb.db.postgresql is disabled
gbi3: warning: component gb.xml.rpc not found
In file included from main.cpp:26:0:
CPdfDocument.h:29:20: fatal error: PDFDoc.h: No such file or directory
 #include <PDFDoc>
                    ^
compilation terminated.
make[2]: *** [gb_pdf_la-main.lo] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.7.1 En Debian 8 
 
tincho:

Creo que lo máximo que se puede instalar en debian (por ahora), es la version  3.6.2 (como experimental) y como testing (sid) 3.5.4

Mirate esta página:
https://packages.qa.debian.org/g/gambas3.html

Pero, sinceramente, yo sigo usando la 3.5.4, y no veo la necesidad de actualizarse a la 3.7.1.


Saludos

Julio
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.7.1 En Debian 8 
 
jsbsan escribió: [Ver mensaje]
...Pero, sinceramente, yo sigo usando la 3.5.4, y no veo la necesidad de actualizarse a la 3.7.1.


Si, en mi falta de experiencia cometí el error de usar la versión "trunk" para desarrollar aplicaciones de producción y a la hora de distribuir el programa me encuentro con el problema de que simplemente no corre en 3.5.4.
Así que estoy haciendo el trabajo de hormiga de quitar todo lo que no funcione y regresar a la versión 3.5.4. pero tengo problemas con el gb.report (en versión 3.7.1 gb.report2) que no me funciona.
me da un error "Unknown symbol 'Data' in class 'ReportSection'" en las propiedades del reporte, pero no logro encontrar donde esta esta propiedad para borrarla.

Todo se debe a que estoy preparando un debian8 persistente en usb (luego te pondré unos comentarios a tu tutorial, que por cierto muchas gracias.)
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.7.1 En Debian 8 
 
Tincho:

Citar:
pero tengo problemas con el gb.report (en versión 3.7.1 gb.report2) que no me funciona.


Creo que el componente gb.report2 solo esta en la version 3.7.X, tendras que usar el gb.report
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.8.4 En Debian 8.2 
 
La versión 3.8.4 es funcional en Debian 8.2, pero me da problemas en la impresión de informes.
¿Alguien lo instalo?

Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.8.4 En Debian 8.2 
 
Con LMDE «Betsy» sólo puedo instalar la 3.5.4

[System]
gambas=3.5.4
OperatingSystem=Linux
Kernel=3.16.0-4-amd64
Architecture=x86_64
Distribution=LMDE 2 Betsy
Desktop=MATE
Theme=QGtk
Language=es_ES.UTF-8
Memory=3964M
[Libraries]
Cairo=libcairo.so.2.11400.0
Curl=libcurl.so.4.3.0
DBus=libdbus-1.so.3.8.13
GStreamer=libgstreamer-0.10.so.0.30.0
GStreamer=libgstreamer-1.0.so.0.404.0
GTK+=libgtk-x11-2.0.so.0.2400.25
OpenGL=libGL.so.1.2.0
Poppler=libpoppler.so.46.0.0
Qt4=libQtCore.so.4.8.6
SDL=libSDL-1.2.so.0.11.4

Intenté actualizarla con PPA, y, lógicamente, me apareció el mensaje «No se admite la adición de PPAs».
No he intentado forzar PPA para no hacer inestable el SO.

... Y hasta aquí mi experiencia de novato. De momento sigo con la 3.5.4.
 



 
Grandamakulo - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.8.4 En Debian 8.2 
 
Citar:

Con LMDE «Betsy» sólo puedo instalar la 3.5.4

¿Seguro? Yo no uso debian, pero si desinstalas completamente la de los repositorios y te bajas el fuente y lo compilas creo que debería funcionarte sin problemas.
 




===================
No podemos regresar
 
shordi - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.8.4 En Debian 8.2 
 
Grandamakulo

LMDE es esta  basado en Debian, alguno de estos repositorios de ubuntu te podría servir:

deb http://ppa.launchpad.net/gambas-team/gambas3/ubuntu trusty main
deb-src http://ppa.launchpad.net/gambas-team/gambas3/ubuntu trusty main


o este...

deb http://ppa.launchpad.net/gambas-team/gambas3/ubuntu vivid main
deb-src http://ppa.launchpad.net/gambas-team/gambas3/ubuntu vivid main


Estos solo te agrarian gambas 3.8.4 a la lista de paquetes. Deberia editar "/etc/apt/source.list" manualmente.
 



 
whisper - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalacion De Gambas 3.8.4 En Debian 8.2 
 
Gracias a ambos por las respuestas.
Shordi, lo intenté y, si bien no puedo poner detalles porque aquello fue tan caótico que ni tomé notas, lo cierto es que no funcionó.
Whisper, me da algo de miedo combinar repositorios (es que tengo poca experiencia), pero lo intentaré y comentaré el resultado.
Un saludo,
 



 
Grandamakulo - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
10.00 10 10 1
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Ayuda Con La Instalacion De Gambas3 En Deb... ratuzz Instalación 2 Sabado, 07 Julio 2012, 22:57 Ver último mensaje
ratuzz
No hay nuevos mensajes Instalacion En Beaglebone Black Con Debian miguelab Instalación 3 Viernes, 06 Febrero 2015, 17:10 Ver último mensaje
shordi
No hay nuevos mensajes Instalacion De Debian Jessie 8.1 En Una Me... tincho General 5 Martes, 16 Junio 2015, 21:19 Ver último mensaje
tincho
No hay nuevos mensajes Script Post Instalacion Para Distribucione... tincho Shell Scripting 2 Lunes, 10 Julio 2017, 14:10 Ver último mensaje
tincho
 

Publicar nuevo tema  Responder al tema  Página 1 de 3
Ir a la página 1, 2, 3  Siguiente

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario