Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Problemas Con USE En La Ejecucion De Un Script En Apache
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Problemas Con USE En La Ejecucion De Un Script En Apache 
 
Hola a tod@s

Estoy intentando ejecutar este script, llamado consulta.cgi, en mi servidor apache...
#!/usr/bin/env gbw2
<%
use "gb.db" 'indico la libreria
Dim myreqnombre as String
Dim myreqapellido as String

myreqnombre = Request["nombre"]
....


(adjunto el archivo, porque me da problemas al insertarlo en el foro)

Pero me da el siguiente error en el navegador:

Citar:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache/2.2.20 (Ubuntu) Server at localhost Port 80


Y viendo el fichero log de apache2 ( /var/log/apache2/error.log ), aparece lo siguiente:
Citar:
[Fri Mar 30 20:33:56 2012] [error] [client 127.0.0.1] /tmp/gambas.33/4639/project.tmp/MMain.module:12: Unknown identifier: Use, referer: http://localhost/inicio.html
[Fri Mar 30 20:33:56 2012] [error] [client 127.0.0.1] , referer: http://localhost/inicio.html
[Fri Mar 30 20:33:56 2012] [error] [client 127.0.0.1] malformed header from script. Bad header=' gambas module file: consulta.cgi, referer: http://localhost/inicio.html



Si borro la linea que empieza por "use", el script funciona perfectamente, pero necesito incluir las librerias de base de datos al script
¿sabeis porque puede darse este problema?

Saludos
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
última edición por jsbsan el Viernes, 30 Marzo 2012, 20:59; editado 11 veces 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problemas Con USE En La Ejecucion De Un Script En Apache 
 
Me parece que es por que usas "use" y no "USE", saludos.
 



 
Enchufadoo - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problemas Con USE En La Ejecucion De Un Script En Apache 
 
Lo he cambiado pero sigue sin funcionar...  
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
última edición por jsbsan el Sabado, 31 Marzo 2012, 12:46; editado 1 vez 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problemas Con USE En La Ejecucion De Un Script En Apache 
 
Ya esta, resuelto....

Aparte de tener que poner use en mayusculas "USE", el problema era el comentario, se lo he quitado y ahora si funciona...

queda la linea finalmente asi:
USE "gb.db"


En mayúsculas y sin comentarios...

Gracias
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Problemas Con CGI Y Ejecucion De Script Pa... jsbsan General 2 Domingo, 15 Abril 2012, 13:32 Ver último mensaje
jsbsan
No hay nuevos mensajes Ayuda Con La Ejecucion De Un Script [soluc... luisrel Shell Scripting 5 Jueves, 25 Noviembre 2010, 09:54 Ver último mensaje
shordi
No hay nuevos mensajes Ejecucion De Preinst, Postinst, Prerm Y Po... destroyer General 0 Miercoles, 08 Diciembre 2010, 12:40 Ver último mensaje
destroyer
No hay nuevos mensajes Diferencias De Crear Un Paquete De Instala... jousseph Instalación 0 Jueves, 30 Agosto 2012, 09:37 Ver último mensaje
jousseph
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario