Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
No Puedo Instalar Gambas 3 En Linux Mint 12
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje No Puedo Instalar Gambas 3 En Linux Mint 12 
 
hola a todos detallo situacion:
el script de instalacion no me funciona->
Comprobaré si 'subversion' está instalado, si no, se instalará ahora

 SVN Instalado, creando directorio...
 Instalando las dependencias de desarrollo para lisa...
 No se cumplen los requisitos, pulsa 'intro' para salir.
con sudo apt-get install gambas3

[sudo] password for claudio:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 gambas3 : Depende: gambas3-gb-opengl-glsl (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-cairo (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-dbus (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-form-stock (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-chart (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-compress-bzlib2 (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-compress-zlib (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-crypt (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-db-form (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-db-mysql (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-db-postgresql (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-db-odbc (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-db-sqlite3 (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-desktop (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-form (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-form-dialog (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-form-mdi (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-gui (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-image (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-info (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-net-curl (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-net-smtp (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-opengl (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-pcre (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-pdf (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-qt4-ext (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-qt4-webkit (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-qt4-opengl pero no va a instalarse
           Depende: gambas3-gb-report (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-sdl-sound (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-settings (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-vb pero no va a instalarse
           Depende: gambas3-gb-v4l (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-web pero no va a instalarse
           Depende: gambas3-gb-xml-rpc (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-xml-xslt (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-ide (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-image-effect (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-image-imlib (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-image-io (>= 3.0.0~oneiric2) pero no va a instalarse
           Depende: gambas3-gb-mysql (>= 3.0.0~oneiric2) pero no va a instalarse
E: Paquetes rotos
ayuuuddaaaa!!!!! gracias
 



 
perezheguy - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Puedo Instalar Gambas 3 En Linux Mint 12 
 
Hola!.

Pues si que te faltan.Todos.

Mint es dependiente de Ubuntu.Debería ser compatible.

En el peor de los casos podrías hacerlo manualmente todo con paciencia.

Para una Natty que seria una Ubuntu 11.04

sudo apt-get install build-essential autoconf libbz2-dev libfbclient2 libmysqlclient-dev unixodbc-dev libpq-dev libsqlite0-dev libsqlite3-dev libgtk2.0-dev libldap2-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libsage-dev libxml2-dev libxslt1-dev libbonobo2-dev libcos4-dev libomniorb4-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev libasound2-dev libesd0-dev libdirectfb-dev libaa1-dev libxtst-dev libffi-dev kdelibs4-dev firebird2.1-dev libqt4-dev libglew1.5-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev
 


Luego sigue los pasos:

Descomprime en algun lugar gamba3.Ve al lugar y ejecutar.

cd lugardondeestagambas3
sudo ./configure -C
sudo make
sudo make install

 


Tienes que ir examinando que componentes te va faltando.Instalarlos y empezar de nuevo.
Los componentes necesarios para gambas3 puedes encontrarlos en:

http://gambasdoc.org/help/install?en&view#t6

Ve mas abajo y veras los componentes.

No tuve problemas con varias versiones de Ubuntu, pero se complicaba con Debian Squeeze, poco a poco lo instale.Una tarde.

Usa el buscador de la comunidad.Hay información importante sobre esto.

Bienvenido a la comunidad.

Saludos.
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Puedo Instalar Gambas 3 En Linux Mint 12 
 
gracias por responder . sigo lidiando y me encuentro esto????
jogi claudio # cd gambas3-3.0.0
jogi gambas3-3.0.0 # sudo ./configure -C
sudo: ./configure: command not found
jogi gambas3-3.0.0 # ./configure -C
bash: ./configure: No existe el fichero o el directorio
jogi gambas3-3.0.0 # ls
acinclude.m4  component.am  depcomp             gb.db.mysql       gb.desktop      gb.net.smtp  gb.sdl.sound  Makefile.am        reconf
aclocal.m4    config.guess  examples            gb.db.odbc        gb.gtk          gb.opengl    gb.v4l        Makefile.in        reconf-all
app           config.h.in   gb.cairo            gb.db.postgresql  gb.image.imlib  gb.pcre      gb.xml        missing            TEMPLATE
AUTHORS       config.sub    gb.compress.bzlib2  gb.db.sqlite2     gb.image.io     gb.pdf       INSTALL       NEWS               TODO
ChangeLog     configure.ac  gb.compress.zlib    gb.db.sqlite3     gb.net          gb.qt4       install-sh    README
comp          COPYING       gb.crypt            gb.dbus           gb.net.curl     gb.sdl       main          README.svn-commit
te muestro dentro de la carpeta descargada.
alguna sugerencia gracias
 



 
perezheguy - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Puedo Instalar Gambas 3 En Linux Mint 12 
 
Cierto.No tienes configure.

Entonces es que falta hacer esto al principio:
./reconf-all

Aquí tienes todo las instrucciones.
./reconf-all
./configure -C
make
sudo make install
 


Sudo es al final, cuando lo instalas.Esa parte me la había saltado.

Saludos.
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
última edición por Shell el Miercoles, 07 Marzo 2012, 01:03; editado 1 vez 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Puedo Instalar Gambas 3 En Linux Mint 12 
 
gracias por responder shell.

adjunto la imposiilidad sigue:

jogi gambas3-3.0.0 # ./reconf-all
./reconf-all: 7: libtoolize: not found
Can't exec "libtoolize": No existe el fichero o el directorio at /usr/bin/autoreconf line 196.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 196.
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal
autoreconf: configure.ac: tracing
autoreconf: configure.ac: adding subdirectory main to autoreconf
autoreconf: Entering directory `main'
autoreconf: running: aclocal -I m4 --install
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf
autoreconf: running: /usr/bin/autoheader
autoreconf: running: automake --add-missing --copy --no-force
gbx/Makefile.am:5: library used but `RANLIB' is undefined
gbx/Makefile.am:5:   The usual way to define `RANLIB' is to add `AC_PROG_RANLIB'
gbx/Makefile.am:5:   to `configure.ac' and run `autoconf' again.
gbx/Makefile.am:6: Libtool library used but `LIBTOOL' is undefined
gbx/Makefile.am:6:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
gbx/Makefile.am:6:   to `configure.ac' and run `aclocal' and `autoconf' again.
gbx/Makefile.am:6:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
gbx/Makefile.am:6:   its definition is in aclocal's search path.
lib/compress/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/compress/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/compress/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/compress/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/compress/Makefile.am:4:   its definition is in aclocal's search path.
lib/db/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/db/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/db/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/db/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/db/Makefile.am:4:   its definition is in aclocal's search path.
lib/debug/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/debug/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/debug/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/debug/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/debug/Makefile.am:4:   its definition is in aclocal's search path.
lib/draw/Makefile.am:3: Libtool library used but `LIBTOOL' is undefined
lib/draw/Makefile.am:3:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/draw/Makefile.am:3:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/draw/Makefile.am:3:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/draw/Makefile.am:3:   its definition is in aclocal's search path.
lib/eval/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/eval/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/eval/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/eval/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/eval/Makefile.am:4:   its definition is in aclocal's search path.
lib/gui/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/gui/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/gui/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/gui/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/gui/Makefile.am:4:   its definition is in aclocal's search path.
lib/image.effect/Makefile.am:5: Libtool library used but `LIBTOOL' is undefined
lib/image.effect/Makefile.am:5:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/image.effect/Makefile.am:5:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/image.effect/Makefile.am:5:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/image.effect/Makefile.am:5:   its definition is in aclocal's search path.
lib/image/Makefile.am:5: Libtool library used but `LIBTOOL' is undefined
lib/image/Makefile.am:5:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/image/Makefile.am:5:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/image/Makefile.am:5:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/image/Makefile.am:5:   its definition is in aclocal's search path.
lib/option/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/option/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/option/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/option/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/option/Makefile.am:4:   its definition is in aclocal's search path.
lib/signal/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/signal/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/signal/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/signal/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/signal/Makefile.am:4:   its definition is in aclocal's search path.
lib/vb/Makefile.am:4: Libtool library used but `LIBTOOL' is undefined
lib/vb/Makefile.am:4:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
lib/vb/Makefile.am:4:   to `configure.ac' and run `aclocal' and `autoconf' again.
lib/vb/Makefile.am:4:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
lib/vb/Makefile.am:4:   its definition is in aclocal's search path.
autoreconf: automake failed with exit status: 1
jogi gambas3-3.0.0 # ./configure -C
bash: ./configure: No existe el fichero o el directorio

gracias por todo
 



 
perezheguy - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Puedo Instalar Gambas 3 En Linux Mint 12 
 
Instala el paquete libtool

$ sudo apt-get install libtool


Saludos!
 



 
razaAztk - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuarioVer la galería personal del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Puedo Instalar Gambas 3 En Linux Mint 12 
 
gracias master!!!!!!!!!
 



 
perezheguy - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.50 0 1 2
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Instalar En Linux Mint 18.2 (SOLUCIONADO) ahtonio Instalación 3 Martes, 21 Noviembre 2017, 00:21 Ver último mensaje
ahtonio
No hay nuevos mensajes [Solucionado] Instalar Gambas3 Con Linux-M... vuott Instalación 3 Sabado, 13 Septiembre 2014, 00:07 Ver último mensaje
vuott
No hay nuevos mensajes Instalar Gambas2 En Linux Mint 16 (Petra) LIberto Instalación 6 Jueves, 06 Marzo 2014, 22:31 Ver último mensaje
alessandri
No hay nuevos mensajes Instalar Gambas2 En Linux Mint 17.3 Y Ubun... alessandri Instalación 4 Lunes, 20 Febrero 2017, 17:22 Ver último mensaje
v3ctor
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario