Componentes Cambian En Gambas 3.12.2


Objetivo: Componentes Cambian En Gambas 3.12.2
Buenas!

Comencemos con Synaptic.

Si busco gambas aparecen componentes de la gambas 3.8.42 y 3.11.4 aunque no estén instalados.

versionesanteriores

¿ No deberían desaparecer ?.

Sigamos. Todos los días suelo usar una aplicación para el trabajo.
Esta hace uso del componente gb.gui.qt. En uno de los ordenadores solucioné este mensaje.

quiereqt5

Pero lo gracioso también es lo que sale en la lista de componentes:

qt4_qt5

Como veis no esta instalado todos los componentes para qt5.
Ahora voy a Synaptic:

componentesgambasqt4yqt5

¿ Y cómo aparece en la lista del editor de gambas el componente qt5 si no está instalado ?.

Saludos

Objetivo: Re: Componentes Cambian En Gambas 3.12.2
Shell:
Respecto a las versiones "viejas" en synaptic, en mi caso no hay ninguna, todos los paquetes listados son nuevos.
Respecto a QT4 y QT5 bueno, seguramente estés usando mate o xfce y en el sistema este instalada la versión 4 pero ya hubo unos cuantos post de eso y al parecer esta solucionado el bug en las versiones mas nuevas (3.12).
Prueba desinstalando gb.qt4 & gb.qt4.ext
Hace un tiempo informe mediante el bugreport 1411 de un error similar y aparentemente esta resuelto en el commit 628aa30e

Saludos.

Perfil MP  
Objetivo: Re: Componentes Cambian En Gambas 3.12.2
Tincho:

Citar:

Respecto a las versiones "viejas" en synaptic, en mi caso no hay ninguna, todos los paquetes listados son nuevos.

Pues esto es algo raro. Debe ser algo que ha quedado residual.
Pero eso no es lo mejor, más abajo.

Citar:

Respecto a QT4 y QT5 bueno, seguramente estés usando mate o xfce y en el sistema este instalada la versión 4 pero ya hubo unos cuantos post de eso y al parecer esta solucionado el bug en las versiones mas nuevas (3.12).
Prueba desinstalando gb.qt4 & gb.qt4.ext


Podría tener las dos supongo. Fui a eliminar los componentes de gb.qt4 y me dice que va a eliminar gambas3 y que va añadir un componente de gb.qt5.
Así que instalé los de qt5 y luego eliminé los de gb.qt4, en ese momento me vuelve a recordar que va a eliminar gambas3.
Lo hace y queda como paquete roto gambas3, algo sobre dependencias.

Salgo de synaptic, actualizo con apt-get update y no se queja de nada.
Vuelvo a ver la lista de paquetes roto, ya no esta.

Arranco gambas y lo hace con normalidad

Voy a Synaptic busco gambas3. Aparecen dos.
gambas3_1547460041_234986

Y el instalado su descripción aparece en ingles, pero con la palabra gambas3-ide.
Sigue mostrándose en español el idioma del editor sin problemas.

ygambas3

Al ejecutar desde la consola:

gambas3 -V


Muestra:

Citar:

3.12.2


Por defecto gb.qt4 aparece en la lista de componentes, aunque en realidad no existe como instalado.
Al igual que pasaba antes con gb.qt5
Ah y con dpkg:

dpkg -l gambas3


Citar:

dpkg-query: no se ha encontrado ningún paquete que corresponda con gambas3


Saludos

última edición por Shell el Lunes, 14 Enero 2019, 11:11; editado 1 vez
Objetivo: Re: Componentes Cambian En Gambas 3.12.2
Si veís:

Gambas3 ppa. Listado extra

Aparece tanto el archivo gambas3 como gambas3-ide. ¿ Es un paquete dummy o de transición ?.

Saludos

Objetivo: Re: Componentes Cambian En Gambas 3.12.2
gambas 3.8 estará en los repositorios oficiales de la distro que uses. gambas 3.12 en el repo de gambas. Por eso tienes dos.

Perfil MP  
Objetivo: Re: Componentes Cambian En Gambas 3.12.2
Shordi:

Citar:

gambas 3.8 estará en los repositorios oficiales de la distro que uses. gambas 3.12 en el repo de gambas. Por eso tienes dos.


Creía que al actualizar con apt-get update solo debían aparecer los más actuales.
También son nombre de paquetes que no existen en la nueva versión y puede que por eso
no lo sustituya.

Ayer vi el contenido del paquete gambas3.No tenía apenas nada, directorios vacíos en el /usr y alguna documentación comprimida con gz.
Hablaba de metapaquete e instalador. Pero no aparecía ni un archivo script.
El tamaño era mínimo.

Aquí no puedo verlo ya que no esta instalado y si quisiera instalarlo, requiere otros paquetes.

paquetesrequeridos

Lo que da a entender es que probablemente cuando se instala gambas, se instale por defecto componentes de qt4 y no qt5.
A lo mejor puede ser cosa de la distro, si esta es Mate u otra distinta y del compilador instalado para qt.
En el sistema se puede tener los dos solo hay que decirle cual quieres usar.

En este sistema por ejemplo:
qmake -v

Da como resultado:
Citar:

QMake version 2.01a
Using Qt version 4.8.7 in /usr/lib/x86_64-linux-gnu


qmake es como enlace al comando que elige la versión de qt.
/usr/bin $ ls -l qmake


Citar:

lrwxrwxrwx 1 root root 9 nov 21 2017 qmake -> qtchooser


Y naturalmente en el sistema tenemos tanto:

Citar:

qmake-qt4 (1) - cross-platform makefile generator for Qt
qmake-qt5 (1) - cross-platform makefile generator for Qt


Si ejecutamos:

qtchooser -list-versions

Obtendremos:
Citar:

4
5
default
qt4-x86_64-linux-gnu
qt4
qt5-x86_64-linux-gnu
qt5


Qt5 ya debe llevar un tiempo, ¿ aun sigue inestable ?.

Saludos

última edición por Shell el Martes, 15 Enero 2019, 09:51; editado 1 vez

Página 1 de 1


  
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario

   

Está utilizando la versión (Lo-Fi). Para ver la versión completa del foro, haga clic aquí.

Powered by Icy Phoenix based on phpBB
Design by DiDiDaDo

Página generada en:: 0.0803s (PHP: 5% SQL: 95%)
Consultas SQL: 21 - Debug off - GZIP Activado