Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Instalar Gambas2 En Linux Mint 17.3 Y Ubuntu 14.04
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Instalar Gambas2 En Linux Mint 17.3 Y Ubuntu 14.04 
 
Hola apreciados amigos de gambas-es
Desde hace unos años me he venido peleado con gambas2 para instalarlo
en Ubuntu 14.04 LTS o Linux Mint 17, y por fin lo he conseguido.

Algunos dirán que ¿porque sigo con gambas2?, bueno la verdad estoy de lleno
con gambas3, pero hay una aplicación muy grande que esta en gamas2 y por
asuntos de tiempo no la he podido migrar a gambas3. Si alguien le pasa lo mismo
puede aprovechar este documento.

Paso1: Instalar los componentes de compilación que son compatibles con ubuntu 13.04, que son (según gambas.sourceforge.net):
sudo apt-get install build-essential autoconf libbz2-dev libfbclient2 libmysqlclient-dev unixodbc-dev libpq-dev libsqlite0-dev libsqlite3-dev libgtk2.0-dev libldap2-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libsage-dev libxml2-dev libxslt1-dev libbonobo2-dev libcos4-dev libomniorb4-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev libasound2-dev libesd0-dev libdirectfb-dev libaa1-dev libxtst-dev libffi-dev kdelibs5-dev firebird2.1-dev libqt4-dev libglew1.5-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev libgsl0-dev

Nota: si ven algún error tras ejecutar el paso 1, no preocuparse ya que funciona de todos modos.

Paso2: ingresar a la pagina http://www.ubuntuupdates.org/package_metas/list?name=gambas2 y descargar todos los paquetes de Gambas2 en formato
.DEB, o bien, entrar en https://launchpad.net

Paso3: Obtener en la misma pagina los siguientes componentes e instalarlos: libqt-mt e instalar

paso4: Numera los paquetes en el orden exacto como se presenta
1-gambas2-dev_2.23.1-1ubuntu3_i386.deb
 2-gambas2-doc_2.23.1-1ubuntu3_all.deb
 3-gambas2-runtime_2.23.1-1ubuntu3_i386.deb
 4-gambas2-gb-compress_2.23.1-1ubuntu3_i386.deb
 5-gambas2-gb-compress-bzlib2_2.23.1-1ubuntu3_i386.deb
 6-gambas2-gb-crypt_2.23.1-1ubuntu3_i386.deb
 7-gambas2-gb-net_2.23.1-1ubuntu3_i386.deb
 8-gambas2-gb-net-curl_2.23.1-1ubuntu3_i386.deb
 9-gambas2-gb-net-smtp_2.23.1-1ubuntu3_i386.deb
 10-libmng1_1.0.10-3_i386.deb
 11-libqt3-mt_3.3.8-b-8ubuntu3_i386.deb
 12-gambas2-gb-qt_2.23.1-1ubuntu3_i386.deb
 13-gambas2-gb-qt-ext_2.23.1-1ubuntu3_i386.deb
 14-gambas2-gb-qt-opengl_2.23.1-1ubuntu3_i386.deb
 15-gambas2-gb-vb_2.23.1-1ubuntu3_i386.deb
 16-gambas2-script_2.23.1-1ubuntu3_i386.deb
 17-gambas2-gb-xml_2.23.1-1ubuntu3_i386.deb
 17-gambas2-gb-xml-rpc_2.23.1-1ubuntu3_i386.deb
 18-gambas2-gb-web_2.23.1-1ubuntu3_all.deb
 18-gambas2-gb-xml-xslt_2.23.1-1ubuntu3_i386.deb
 19-gambas2-gb-settings_2.23.1-1ubuntu3_all.deb
 20-gambas2-gb-pcre_2.23.1-1ubuntu3_i386.deb
 21-gambas2-gb-info_2.23.1-1ubuntu3_all.deb
 22-gambas2-gb-gtk_2.23.1-1ubuntu3_i386.deb
 23-gambas2-gb-gtk-ext_2.23.1-1ubuntu3_i386.deb
 24-gambas2-gb-gtk-svg_2.23.1-1ubuntu3_i386.deb
 25-gambas2-gb-sdl_2.23.1-1ubuntu3_i386.deb
 26-gambas2-gb-sdl-sound_2.23.1-1ubuntu3_i386.deb
 27-gambas2-gb-image_2.23.1-1ubuntu3_i386.deb
 28-gambas2-gb-opengl_2.23.1-1ubuntu3_i386.deb
 29-gambas2-gb-gui_2.23.1-1ubuntu3_i386.deb
 30-gambas2-gb-form_2.23.1-1ubuntu3_all.deb
 31-gambas2-gb-form-dialog_2.23.1-1ubuntu3_all.deb
 32-gambas2-gb-form-mdi_2.23.1-1ubuntu3_all.deb
 33-gambas2-gb-desktop_2.23.1-1ubuntu3_i386.deb
 34-gambas2-gb-db_2.23.1-1ubuntu3_i386.deb
 35-gambas2-gb-db-form_2.23.1-1ubuntu3_all.deb
 36-gambas2-gb-db-odbc_2.23.1-1ubuntu3_i386.deb
 37-gambas2-gb-db-postgresql_2.23.1-1ubuntu3_i386.deb
 38-gambas2-gb-db-mysql_2.23.1-1ubuntu3_i386.deb
 39-gambas2-gb-db-firebird_2.23.1-1ubuntu3_i386.deb
 40-gambas2-gb-db-sqlite2_2.23.1-1ubuntu3_i386.deb
 41-gambas2-gb-chart_2.23.1-1ubuntu3_all.deb
 42-gambas2-gb-db-sqlite3_2.23.1-1ubuntu3_i386.deb
 43-gambas2-gb-report_2.23.1-1ubuntu3_all.deb
 44-gambas2-ide_2.23.1-1ubuntu3_i386.deb

Paso5 -añadir el repositorio de qt3 para ubuntu 14.04 y linux mint 17.3
echo "deb http://archive.ubuntu.com/ubuntu precise main universe multiverse" | sudo tee /etc/apt/sources.list.d/precise.list

Paso6: actualizar la source list
sudo apt-get update

Paso7: instalar qt3 tools
sudo apt-get install qt3-dev-tools

Paso8: instalar el configurador de qt3, o sea, qtconfig desde synaptic
qt3-qtconfig

Paso9: instalar el tema de de poliester de kde desde synaptic para que las aplicaciones se vean nitidas
kde-style-polyester
polymer

paso10: entrar en qt3 configuration y habilitar el GUI adecuado
polymer

Paso11: ejecutar un   sudo su     en la consola

Paso12: ahora como superusuario entra en la carpeta donde están los componentes de gambas2 que has descargado y ejecutar
sudo dpkg -i *.deb

Y ya esta listo, gambas2 en linux mint 17.3

Espero les sea de ayuda, gracias.
 



 
última edición por alessandri el Miercoles, 28 Noviembre 2018, 21:30; editado 1 vez 
alessandri - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalar Gambas2 En Linux Mint 17.3 Y Ubuntu 14.04 
 
Salvo para un ordenador dedicado en exclusiva a esa tarea de gambas2, no le veo utilidad. Después de hacer todo eso tendrás que desactivar las actualizaciones, evitar que el usuario instale nada, etc. etc. porque en el momento que te suban de versión una de las dependencias ya la has petado...

Alguna vez en mi vida me he encontrado con un caso así, por ejemplo: (Sigue una anécdota viejuna y aburrida, estáis avisados)

Allá por el inicio de los 90, en el trabajo pusieron un sistema de fichar con una tarjetita de banda magnética que funcionaba con un aparato con MSDOS-6.2, un hardware de la época y un software propio de la aplicación. Funcionaba bien.
Pasó el tiempo y la máquina, que sólo se dedicaba a eso, se estropeó. Hardware nuevo y el programa dejó de funcionar. Ni poniéndole el mismo sistema operativo ni nada de nada. Al parecer las librerías de acceso a los puertos serie que utilizaba el programa no eran compatibles con los puertos series o algo así. El técnico estuvo tres días completos enganchado al teléfono y delante del aparato hasta que emitió el diagnóstico:

"El software es demasiado viejo. Hay que subir la versión. Cuesta 1.100.000 pesetas (unos 9.000 € de ahora teniendo en cuenta la inflación)"

A mí me dio cierto coraje de tanta inutilidad (había visto cómo el pardillo del técnico no tenía de idea) y le dije a mi jefe:

"Si me autorizas te hago yo el programa por lo que valga un lector de código de barras".

Me autorizó, por supuesto, y así hice uno de mis programas estrellas en la administración. Controlaba las horas de entrada y salida, las vacaciones, los trienios, los permisos, la centralita telefónica y no recuerdo qué más.
Cuando llevaba cinco años de funcionamiento me marché de la empresa y luego me enteré que siguió funcionando sin problemas siete años más, cuando lo sustituyeron por uno con lector de huellas digitales.
Teniendo en cuenta que no les dejé el código fuente y no podían modificarlo, me sentí muy orgulloso de haber hecho un software tan sólido, flexible y previsor como para durar tanto tiempo.

La moraleja es que aquél programa que quedó obsoleto no pudo soportar el cambio de hardware ni sus creadores pudieron actualizarlo. El contrato de mantenimiento anual, que es donde ellos llevaban su negocio, lo perdieron por no echar el rato en actualizar y preveer.

Gambas2 está muerto, no es buena idea programar para zombies... (es broma)    
 




===================
No podemos regresar
 
shordi - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalar Gambas2 En Linux Mint 17.3 Y Ubuntu 14.04 
 
hola, shordy

Como dije "estoy de lleno en gambas3", pero por el momento no me puedo dedicar
a traducir un programa de dotación de personal que es muy grande (de mi propiedad),
así que a mi me ha servido de mucho ya que logré facturar a un cliente nuevo el
programa por una suma muy, muy, muy buena...

Si las cosas se complican, en unos tres años ya lo tendré listo para producción.
 



 
alessandri - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalar Gambas2 En Linux Mint 17.3 Y Ubuntu 14.04 
 
Hola, amigos,

el procedimiento que describí para Linux mint 17.3 también funciona
perfectamente en Linux Mint 18.1, basado en Xenial, o sea que
también funciona en Ubuntu 16.

O sea que el zombi Gambas2 tiene vida por un par de años mas.  
 



 
última edición por alessandri el Domingo, 19 Febrero 2017, 23:38; editado 1 vez 
alessandri - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalar Gambas2 En Linux Mint 17.3 Y Ubuntu 14.04 
 
muy buen trabajo, gracias por el manual

y entiendo las dos razón que son válidas.

una es no tocar algo que funciona perfecto y además se esta cobrando por ello, de ahí la buena razón para mantenerlo en gambas dos.
(no tocar el código para no dar lugar a errores y enojos o complicaciones en el servicio del producto)

y la otra razón la de actualizar el software.

no esperes a que surja el problema, yo diría que tienes que actualizar a gambas tres urgente mas si te esta dando dividendos.

es decir dejar el software en gambas dos sin tocarlo (el que usa el cliente)

pero tu aparte en maquinas de pruebas..... ir actualizándolo a gambas tres y ahorrando tiempo antes que se presente un problema que obviamente te obligara a actualizar a gambas 3 que le falta muy poco para la versión 4.

Saludos.
 




===================
Software libre, programación libre, vida libre es la Public function Libertad()as Invendible
Proyectos: VisorRV1960,Taller2015,Tanteador
https://sourceforge.net/u/v3ctor-full/profile/
Blog: http://novatocodegambas.blogspot.com.uy/
 
v3ctor - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Instalar Gambas2 En Linux Mint 16 (Petra) LIberto Instalación 6 Jueves, 06 Marzo 2014, 22:31 Ver último mensaje
alessandri
No hay nuevos mensajes [Solucionado] Instalar Gambas3 Con Linux-M... vuott Instalación 3 Sabado, 13 Septiembre 2014, 00:07 Ver último mensaje
vuott
No hay nuevos mensajes Instalar Gambas2.23 En Ubuntu 13.04 (Resue... alessandri Instalación 2 Domingo, 19 Febrero 2017, 04:40 Ver último mensaje
alessandri
No hay nuevos mensajes Instalar En Linux Mint 18.2 (SOLUCIONADO) ahtonio Instalación 3 Martes, 21 Noviembre 2017, 00:21 Ver último mensaje
ahtonio
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 0 invitados
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario