Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Instalar Gambas2.23 En Ubuntu 13.04 (Resuelto)
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Instalar Gambas2.23 En Ubuntu 13.04 (Resuelto) 
 
Hola colegas,

Me encontré con el problema de que los Mother Board que están llegando a mi país no tienen buena compatibilidad
con ubuntu 10.04 y 11.04, los cuales utilizo para vender mis programas desarrollados en gambas2, pero el ubuntu 13.04
funciona muy bien en todos los Mother Board que he probado. El problema era que no podía instalar Gambas2
en ubuntu 13.04 y gambas3 todavía no funciona muy bien (Ej: tiene problemas en el editor, el traductor de GB2 a GB3 no traduce todo,
problemas con el punto y la coma en las cantidades, problemas con la fecha en DD/MM/YYYY  solo funciona en ingles, entre otras cosas
y mis clientes no se adaptan a cosas como escribir la fecha en otro formato, por tanto sigo con Gambas2 que para mis aplicaciones
financieras esta PERFECTO).    

EXPONGO MI SOLUCIÓN

Paso1: Instalar los componentes de compilación que son compatibles con ubuntu 13.04, que son (según gambas.sourceforge.net):
sudo apt-get install build-essential autoconf libbz2-dev libfbclient2 libmysqlclient-dev unixodbc-dev libpq-dev libsqlite0-dev libsqlite3-dev libgtk2.0-dev libldap2-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libsage-dev libxml2-dev libxslt1-dev libbonobo2-dev libcos4-dev libomniorb4-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev libasound2-dev libesd0-dev libdirectfb-dev libaa1-dev libxtst-dev libffi-dev kdelibs5-dev firebird2.1-dev libqt4-dev libglew1.5-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev libgsl0-dev

Paso2: ingresar a la pagina http://www.ubuntuupdates.org/package_metas/list?name=gambas2 y descargar todos los paquetes de Gambas2 en formato
.DEB

Paso3: Obtener en la misma pagina los siguientes componentes e instalarlos: libpoppler19 y libqt-mt

Paso4: Instalar todos los paquetes en el orden exacto como lo indico a continuación: (haa... no me funciono dpkg -i *.deb y use Gdebi en vez de Soft Center) (y no funciona el script que esta disponible en la portada de este sitio, no funciona en ubuntu 13.04)

1- gb-runtime
2- gb-doc
3- gb-pdf
4- gb-qt
5- gb-gtk
6- gb-gtk-ext
7- gb-gtk-svg
8- gb-gui
9- gb-setting
10- gb-form
11- gb-form-dialog
12- gb-form-mdi
13- gb-dev
14- gb-qt-ext
15- gb-db
16- gb-desktop
17- gb-ide
18- gb-net
19- gb-net-curl
20- gb-net-smtp
21- gb-report
22- gb-vb
23- gb-web
24- gb-xml
25- gb-xml-rpc
26- gb-xml-xslt
27- gb-script
28- gb-sdl
29- gb-sdl-sound
30- gb-qt-opengl
31- gb-pcre
32- gb-opengl
33- gb-info
34- gb-image
35- gb-db-sqlite2
36- gb-db-sqlite3
37- gb-db-postgresql
38- gb-db-odbc
39- gb-db-mysql
40- gb-db-firebird
41- db-crypt
42- gb-compress
43- gb-compress-bzlib2
44- gb-db-form
45- gb-chart

ahora solo debemos escribir gambas2 en el lanzador de aplicaciones de ubuntu 13.04 y Listo...

Saludos

 

 



 
alessandri - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalar Gambas2.23 En Ubuntu 13.04 (Resuelto) 
 
Hola Alessandri.

Supongo que a lo mejor es posible hacer esto en otras distros compatibles con Ubuntu.

Hoy probare con una Linux Mint 14. A ver que hace. De todas maneras ya no uso Gambas2, por muchos motivos a estas alturas.
El único motivo que queda es que por necesidad deba usarla.

Dijiste gambas 2.23, no recuerdo cual fue la ultima que incluía Ubuntu. Pero la ultima versión me parece que fue la 2.24.
Lo recomendable sería Gambas3.

Observaciones.

Tus clientes no tienen por que escribir la fecha en un formato u otro, tu tienes que darle la posibilidad con una función.
A menos que uses un componente que exigía un formato de fecha determinado.

Puedes sustituir la coma por el punto o viceversa con una función de Gambas.
Si el lenguaje no te da una posibilidad , lo tienes que inventar.

Si la aplicación es extensa, es normal que no quieras actualizarla a Gambas3. A veces no compensa.
Que extraño que las placas no fueran con algunas versiones de Ubuntu.  

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Instalar Gambas2.23 En Ubuntu 13.04 (Resuelto) 
 
Hola amigos,
por si les interesa voy a abrir otro post sobro como instalar
gambas2 en linux mint 17.3 y ubuntu 14.04 LTS.
 



 
alessandri - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
6.00 2 10 2
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Acabo De Instalar Ubuntu 9.10 shordi General 11 Domingo, 01 Noviembre 2009, 21:28 Ver último mensaje
shordi
No hay nuevos mensajes Instalar Gambas2-2.20.2 Fedora 12 chen_08 Instalación 2 Jueves, 29 Abril 2010, 02:37 Ver último mensaje
chen_08
No hay nuevos mensajes Instalar Gambas 3 En Ubuntu 11.04 Guy Instalación 53 Domingo, 06 May 2012, 18:50 Ver último mensaje
tonixs
No hay nuevos mensajes Instalar Gambas2 En Linux Mint 17.3 Y Ubun... alessandri Instalación 4 Lunes, 20 Febrero 2017, 17:22 Ver último mensaje
v3ctor
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 0 invitados
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario