Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Arch Y Derivadas - Error Gambas No Funciona [SOLUCIONADO]
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Arch Y Derivadas - Error Gambas No Funciona [SOLUCIONADO] 
 
Hola a todos, estoy tratando de utilizar gambas en Manjaro y Antergos, que como saben derivan de Arch.
El caso es que en ambas distros gambas da el siguiente error.
Citar:
gb.gui.qt.webkit: unable to load 'gb.qt4.webkit' component
ERROR: #2: Cannot load class 'HelpView': Cannot load parent class: Cannot load class 'WebView': Unable to load class file


Saludos.
 



 
última edición por tincho el Viernes, 07 Septiembre 2018, 09:36; editado 1 vez 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Arch Y Derivadas - Error Gambas No Funciona 
 
Hola.
Pues que raro, yo he estado programmando en Manjaro sin ningún problema hace tres días. Se que en Manjaro los componentes Qt4 no existen, con lo cual tienes que usar Qt5. Mira en Añadir/Quitar programas que dependencias te faltan de gambas, e instala el componente webkit.qt5 a ver si funciona.
Un saludo.
 



 
Guizans - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Arch Y Derivadas - Error Gambas No Funciona 
 
Guizans escribió:  
...en Manjaro los componentes Qt4 no existen, con lo cual tienes que usar Qt5. Mira en Añadir/Quitar programas...

Si es como dices, he quitado los componentes que llevan qt4, que son dos, y todo solucionado, muchas gracias.

Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Arch Y Derivadas - Error Gambas No Funciona [SOLUCIONADO] 
 
Tincho:

Las dos librerías QT4 y QT5  dudo que puedas usarlas las dos a la vez si tienes oportunidad con gambas.  

Con Linux Mint 18.3 instalada de cero, esperaba encontrarme por defecto QT5, pero no fue así y gambas usaba
QT4. Luego más adelante vi la forma que ya ni me acuerdo y publiqué en la comunidad de como cambiar a QT5.

La idea es que si se instala una distro prácticamente nueva ( cuando lo era ) era encontrarte las librerías más modernas
y en este caso un equipo nuevo. Pues no fue así con QT.  

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Arch Y Derivadas - Error Gambas No Funciona [SOLUCIONADO] 
 
Shell escribió:  
...Las dos librerías QT4 y QT5  dudo que puedas usarlas las dos a la vez...

No iban por ahí los tiros. Gracias igualmente por comentar.

Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario