Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Averiguar Dependencias De Un Paquete De Instalación
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Averiguar Dependencias De Un Paquete De Instalación 
 
Buenas!. Y si ,es que las hay muy buenas últimamente con el verano!.  

Hay dos formas de averiguar las dependencias de un paquete de instalación.
Pero me encontré problemas.

Volviendo al emulador. Se llama mame. Entonces si yo quisiera instalarlo solo tendría que decir:

sudo apt-get install mame
 


Valee!.

Pero y si quiero averiguar las dependencias de este.  

Pues bien esta web nos da la respuesta. ( Pero como soy un lanzao  y me gustan las aventuras y los líos, leo lo mínimo..pa que, pa que, pa que ).

Averiguar las dependencias de un paquete binario
Podemos tener instalado el paquete o no instalado.

Se que tengo instalado el paquete ya que:

Que te veo!.

Citar:

/var/cache/apt/archives $ ls *mame*
mame_0.152-0ubuntu2_amd64.deb  mame-tools_0.152-0ubuntu2_amd64.deb


Ahora bien. Como lo tengo instalado. Debería usar:
dpkg-deb -I mipaquete.deb
 


mi paquete, mi paquete, vaya nombre!. Cuanto necesitado esta la gente de Linux!.

Y esto dice del niño!.

Citar:

 dpkg-deb -I mame_0.152-0ubuntu2_amd64.deb
 paquete debian nuevo, versión 2.0.
 tamaño 14459540 bytes: archivo de control= 2019 bytes.
      19 bytes,     1 líneas     conffiles            
    1169 bytes,    19 líneas     control              
    1459 bytes,    21 líneas     md5sums              
     949 bytes,    33 líneas  *  postinst             #!/bin/sh
     160 bytes,     5 líneas  *  postrm               #!/bin/sh
     427 bytes,    18 líneas  *  prerm                #!/bin/sh
 Package: mame
 Version: 0.152-0ubuntu2
 Architecture: amd64
 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
 Installed-Size: 76654
 Depends: libc6 (>= 2.14), libexpat1 (>= 2.0.1), libflac8 (>= 1.3.0), libfontconfig1 (>= 2.9.0), libgcc1 (>= 1:4.1.1), libjpeg8 (>= 8c), libportmidi0, libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.7.0~beta1), libsdl-ttf2.0-0, libsdl1.2debian (>= 1.2.11), libstdc++6 (>= 4.6), libx11-6, libxinerama1, zlib1g (>= 1:1.1.4), mess-data (= 0.152-0ubuntu2)
 Suggests: gnome-video-arcade, mame-extra, mame-tools
 Section: non-free/games
 Priority: optional
 Homepage: http://mamedev.org/
 Description: Multiple Arcade Machine Emulator (MAME)
  MAME is a hardware emulator: it faithfully reproduces the behavior of many
  arcade machines (it is not a simulation). This program is not a game but can
  directly, through ROM images, run the complete system of these old arcade
  machines. These ROMs are subject to copyright and it is in most of the cases
  illegal to use them if you do not own the arcade machine.
  .
  This package provides the MAME binary and configuration files.
 Original-Maintainer: Cesare Falco <c.falco@ubuntu.com>


Ahora fijaros. Si yo hago esto:

apt-cache depends mame
 


Y me muestra...

Citar:

Depende: libc6
  Depende: libexpat1
  Depende: libflac8
  Depende: libfontconfig1
  Depende: libgcc1
  Depende: libjpeg8
  Depende: libportmidi0
  Depende: libqtcore4
  Depende: libqtgui4
  Depende: libsdl-ttf2.0-0
  Depende: libsdl1.2debian
  Depende: libstdc++6
  Depende: libx11-6
  Depende: libxinerama1
  Depende: zlib1g
  Depende: mess-data
  Sugiere: gnome-video-arcade
  Sugiere: mame-extra
  Sugiere: mame-tools
  Entra en conflicto: mame:i386


¿ Conflicto ? grande_peur

Y así, un rato de tranquilad (hasta que vuelva al sexo duro). Vuelvo al fregao!.

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Averiguar Dependencias De Un Paquete De Instalación 
 
Puñetitas:

Pues que si un empaquetador conoce las dependencias de un paquete. Puede
que este paquete como en el caso de la compilación de M.A.M.E necesita como
mínimo el GCC 5 o mayor. Tendría que añadirlo el empaquetador.
Quizás eso sea liarlo más y más trabajo para el.  

Y es algo que no viene con el propio sistema.
Ya que una Linux Mint 17.3 de 64b trae la GCC 4.8.4.

Lo gracioso de estas cosas. Es que comienza a configurar y luego..Meeec!, que falta uno más alto!.
Y a lo mejor, se lleva un buen rato.

De vuelta al trato con el cliente:
 army

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
última edición por Shell el Jueves, 13 Julio 2017, 14:45; editado 1 vez 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario