Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Qt4 O Qt5
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Qt4 O Qt5 
 
Buenos días!.

Ale que hay que despertar. ¿ Duermen las gambas ?.

¿ Quien le dice a gambas que versión de QT debe usar ?.
Según el comando Qmake en este ordenador:

qmake -v
 


La respuesta fue:

Citar:

QMake version 2.01a
Using Qt version 4.8.7 in /usr/lib/x86_64-linux-gnu


Así que la respuesta es clara. QT4.
En el de casa me dice que la versión de Qmake ronda la 3.x
y la versión de QT es la 5.x. Pero, sigo usando QT4 (Que no me importa).
gambas no eligió QT5 por defecto.

¿ Debe ser que el programador debe elegir los paquetes adecuados ?.
Por otro lado, Qt4 parece convivir con Qt5...por ahora.
 
Ah y también recordar que en Synaptic tenemos qt5-qmake y qt4-qmake.
Cuando construimos binarios que usan esta librería son archivos que terminan con
la extensión .pro (proyecto).( Para los que no usan gambas). Deben ser de "C".

Normalmente se usa la orden qmake que parece un enlace a qtchooser. Lo cierto es que para
compilar un proyecto no podía usar  qmake y si "qt4-qmake" y se compiló correctamente.

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Qt4 O Qt5 
 
Creo, que lo que sucede es algo parecido a una de las actualizaciones anteriores.
Explico lo que paso aquella vez, ya que todavía no actualice a 3.11.3,  en aquella oportunidad usaba dos sistemas un debian y otro ubuntu (con el ppa de gambas team estable, que era una version mas alta que los repos debian) el caso es que usaba los componentes (el problema pasa por estos) gb.qt4 y en debian estaba la version qt5, lo cual no era compatible así que había que crear el ejecutable en cada sistema según sea el caso de qt4 o qt5 lo cual no era mayor problema.
Que paso? que los componentes para qt5 no estaban completados y si usabas algo de gb.qt4, o viceversa, que no estaba   en la otra el programa no funcionaria.
Bueno es un pequeño precio que hay que pagar por disponer de un IDE que permite hacer un solo código para dos tipos de entornos gráficos algo que no se si se puede hacer con otros sistemas de crecion de programas.
Lo que yo suelo hacer y ue casi siempre funciona bien es usar los componentes genéricos gb.gui y de acuerdo al sistema que uses se creara el ejecutable con QT o GTK segun sea el caso.
 componentes_1527102448_651600
Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Qt4 O Qt5 
 
Creo, que lo que sucede es algo parecido a una de las actualizaciones anteriores.
Explico lo que paso aquella vez, ya que todavía no actualice a 3.11.3,  en aquella oportunidad usaba dos sistemas un debian y otro ubuntu (con el ppa de gambas team estable, que era una version mas alta que los repos debian) el caso es que usaba los componentes (el problema pasa por estos) gb.qt4 y en debian estaba la version qt5, lo cual no era compatible así que había que crear el ejecutable en cada sistema según sea el caso de qt4 o qt5 lo cual no era mayor problema.
Que paso? que los componentes para qt5 no estaban completados y si usabas algo de gb.qt4, o viceversa, que no estaba   en la otra el programa no funcionaria.
Bueno es un pequeño precio que hay que pagar por disponer de un IDE que permite hacer un solo código para dos tipos de entornos gráficos algo que no se si se puede hacer con otros sistemas de crecion de programas.
Lo que yo suelo hacer y ue casi siempre funciona bien es usar los componentes genéricos gb.gui y de acuerdo al sistema que uses se creara el ejecutable con QT o GTK segun sea el caso.
 componentes_1527102448_651600
Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Qt4 O Qt5 
 
Buenos días Tincho.

Vaya, se te repitió el mensaje.

¿ Usas gb.gui ?.  

Puede que sea un error y parezca que estén marcados todos los componentes pero realmente no usas
tantos en tu proyecto. Eso era un error antiguo de gambas, pero creo que se solucionó.

Para evitarte problemas de selección si QT4 o QT5 deberías usar gb.gui.qt.
Creo que con esto puedes solucionar problemas de las aplicaciones.
Julio estuvo hablando de este problema hace tiempo. Que luego no iban las aplicaciones con QT4.

¿ Puede influir datos de la home del usuario que le digan al sistema si esta usando QT4 o QT5 ?.
(Un archivo de configuración)

Tanto en el ordenador del trabajo como en el de casa uso Linux Mint 18.2. Sistemas iguales.
En el del trabajo la home del usuario lleva mas tiempo, ha tenido más actualizaciones.
Y en el equipo de casa era prácticamente nuevo. Salvo datos que le copie de los otros ordenadores.

Lo curioso es que siendo sistemas iguales, que sea en el del trabajo una versión de Qmake menor.
Eso me resulta bastante raro.

Puede que no me convenga tener en un sistema QT5 y en los otros QT4.
QT5 era un poco más verde.

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Qt4 O Qt5 
 
Para obtener algo más de información de las versiones instaladas en el sistema:
Podemos usar el comando qtchooser

qtchooser -list-versions
 


Salida en este ordenador:

Citar:

4
5
default
qt4-x86_64-linux-gnu
qt4
qt5-x86_64-linux-gnu
qt5


qtchooser -print-env
 


Salida en este ordenador:

Citar:

QT_SELECT="default"
QTTOOLDIR="/usr/lib/x86_64-linux-gnu/qt4/bin"
QTLIBDIR="/usr/lib/x86_64-linux-gnu"


Suponía que el sistema de alguna forma haría estas cosas más automáticamente.  

Si vamos al directorio:

Citar:

/usr/lib/x86_64-linux-gnu/qt-default/qtchooser/default.conf


Y lo abrimos. A los que usamos QT4 podemos ver algo como esto:

Citar:

/usr/lib/x86_64-linux-gnu/qt4/bin
/usr/lib/x86_64-linux-gnu


Según un post encontrado que os mostraré. Se debería hacer esto:
Se debería cambiar la primera línea por esto:

Citar:

/usr/lib/x86_64-linux-gnu/qt5/bin


Aquí tenéis la referencia que encontré:

Cómo cambiar la versión de QT usada por Qmake.

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
última edición por Shell el Jueves, 24 May 2018, 12:53; editado 1 vez 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Qt4 O Qt5 
 
Ahora la pregunta es:

¿ Merece la pena cambiar a QT5 ?.

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario