Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 2
Ir a la página 1, 2  Siguiente
 
Nueva Versión De Gambas3.10
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Nueva Versión De Gambas3.10 
 
Bueno, pues el dia 6 de agosto, publico Benoit, la nueva versión de gambas3, la 3.10, con cambios sobre todo en los componentes web.

En mi blog, he traducido (con ayuda del google), el changelog

http://jsbsan.blogspot.com.es/2017/...ambas3-310.html

Habrá que esperar un poco para verla en el repositorio ppa.

Saludos
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
Julio:

Pues parece que ya ha salido.

Algo que he visto de pasada en el menú de depuración es sobre la opción GUI. Donde se escoge si usas QT4, QT5, GTK+2, GTK+3, o la de por defecto del escritorio.
Entonces ya no se hace esto desde el menú de componentes, por lo que parece.

Saludos
 




===================
Gambas Básico
“Lo mejor de los booleanos es que si te equivocas estás a un solo bit de la solución correcta. Anónimo."
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
Shell:

Si, ayer por la noche apareció y la instalé, pero aunque decia que era la 3.10 en el update de linux mint, luego resulta que ponia el ide 3.9.90 (o algo asi), creo que ya lo han comentado en las listas internacionales.
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
Alguien ha abierto un proyecto de gambas 3.9.2 con la nueva versión y luego guardado este y luego lo volvió a abrir con la versión viaja en otra maquina ??
Lo pregunto por si hay algo que no funciona como en su momento paso con gb.report  > gb.report2 o gb.qt4.ext.

En xubuntu 16.04 LTS la verson de gambas es la 3.9.90
 gambas_9_9_90
Acabo de actualizarla, veremos que tal va.

Saludos.
 



 
última edición por tincho el Jueves, 24 Agosto 2017, 14:46; editado 1 vez 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
Actualice la versión y en la ventana de inicio aparece "gambas 3 - DEVELOPMENT VERSION, USE AT YOUR OWN RISK!"

Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
yo les recomiendo usar la version estable para trabajar, en el pasado tuve problemas con la TRUNK, y no necesito mas problemas que los que me plantea mi propio codigo!!!!
 



 
tercoIDE - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
Si, yo también tuve problemas con una DEVELOPMENT VERSION, USE AT YOUR OWN RISK! anterior pero bueno tampoco esta mal hacer algunas pruebas porque asi se descubren mas rápido los errores.
De todas maneras eche un vistazo al PPA de Sebikul y vi que lo actualizo hace una hora, así que volví a hacer apt-get dist-upgrade pero sigue siendo la versión 3.9.90
 y sigue apareciendo el mensaje DEVELOPMENT VERSION, USE AT YOUR OWN RISK!.

Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
Esto fue por la migracion al nuevo manejo de codigo con git. Es la version estable, pero quedo erroneo el numero de version. Ya esta compilandose un nuevo set de paquetes, en unas horas deberia estar solucionado.
 



 
sebikul - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
sebikul escribió: [Ver mensaje]
Esto fue por la migración al nuevo manejo de código con git. Es la versión estable, pero quedo erróneo el numero de versión. Ya esta compilandose un nuevo set de paquetes, en unas horas debería estar solucionado.

Que groso chabón !! Muchas gracias.

Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Nueva Versión De Gambas3.10 
 
Volvi a instalar, pero esta vez cuando intente sudo apt-get dist-upgrade no arrojo ninguna actualización puesto que se trataba de la misma versión, así que hice lo siguiente:
sudo apt-get remove --purge gambas3*
sudo apt-get install gambas3
Nota: si tienen algún programa instalado que dependa de gambas, tal vez se los desinstale también, atención.
Pero luego la versión que se instala sigue diciendo 3.9.9 y aparece el mensaje "DEVELOPMENT VERSION, USE...."

Pero si me fijo en Synaptic

Version instalada: 3.10.0+git5947.00a83e1+build1.bca3d02.1.fb554bc~ubuntu16.04.1
Versión disponible: 3.10.0+git5947.00a83e1+build1.bca3d02.1.fb554bc~ubuntu16.04.1

Con lo cual infiero que el paquete de la rama ESTABLE tiene un error que hace que la versión que se ve en el splash de inicio de gambas sea 3.9.90 y aparesca el mensaje "DEVELOPMENT VERSION, USE...."

También el archivo .project de un proyecto creado con esta versión de gambas dice:
Citar:
# gambas Project File 3.0
# Compiled with gambas 3.9.90
Title=gb.media
Startup=FMain
Version=0.0.1
...


En gitlab
gambas-master-a527b9cdc2cb32f95454c27f3f019b2cac7bbb16
master   default  Select Archive Format
a527b9cd · Add control pictures in 'gb.term.form'.  · about 4 hours ago

gambas-stable-9786d957590ab71c2a7c874fea51580f4135988c
stable   Compare Select Archive Format
9786d957 Update acinclude.m4.  · about 3 hours ago

Así que creo que a la versión estable le faltan unos retoques porque la estable es la 3.10.0 y la master es la 3.10.90. que es coerente con lo que compilo Sebikul.

Saludos.
 



 
tincho - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Juego De Las Palabras(ex Juego Del Cine) N... Dani26 Aplicaciones/Fragmentos de Código 1 Domingo, 11 Septiembre 2011, 05:44 Ver último mensaje
ivanovichenco
No hay nuevos mensajes Nueva Versionde Gambas3: Gambas3.8 jsbsan General 8 Miercoles, 05 Agosto 2015, 16:40 Ver último mensaje
sebikul
No hay nuevos mensajes Error En Instalacion De Nueva Versión v3ctor General 6 Jueves, 24 Diciembre 2015, 17:56 Ver último mensaje
v3ctor
No hay nuevos mensajes Actualizar A Una Nueva Versión De Una Distro Shell Mundo Linux 5 Miercoles, 22 Noviembre 2017, 23:21 Ver último mensaje
tincho
 

Publicar nuevo tema  Responder al tema  Página 1 de 2
Ir a la página 1, 2  Siguiente

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario