Gambas 3.3.1


Objetivo: Gambas 3.3.1
Hola Comunidad!.

Tenemos versión nueva que repara la 3.3.0!.

Citar:

25 Sep 2012

gambas 3.3.1 has been released.

This release fixes some last-minute annoying bugs of gambas 3.3. You should really use it instead of the 3.3.0 version.

See the Release Notes for the list of bug fixes.

24 Sep 2012

gambas 3.3 has been released.

This new release fixes more than 250 bugs and adds more than 250 new features.

The main changes are:

A far more reliable packager.
Automatic local variable declaration.
TODO/FIXME/NOTE comments listing.
Bookmarks in text and code editor.
Background tasks.
Compilation warnings on unused variables, unused functions and overridden symbols.
Support for complex numbers based on a new gb.complex component.
A new gb.data component that adds new container datatypes to gambas.
Support for tablets and pens in GUI components.
The gb.gsl component now implements polynomials, matrices, vectors and complex numbers completely.
Arithmetic operators work with polynomials, matrices, vectors and complex numbers.
A new gb.mime component that allows to encode and decode MIME messages.
A new gb.net.pop3 component that implements a POP3 client.

See the Release Notes for the list of all new features and bug fixe


A ver que os parece sus cambios.Que la disfruten.


Saludos.

Objetivo: Re: Gambas 3.3.1
A mi me da un error en el Ide de gambas 3.3.0 y 3.3.1, cuando le doy a alguna propiedad que tenga el boton de "..." , salta este error y sale de gambas3

error_gambas3_3_1






En cuanto las mejoras, no he las he probado, pero me parece interesante el tema de ya tener tipo de datos de matrices (y sus operaciones: invertir, determinante, etc.. ) http://gambasdoc.org/help/comp/gb.gsl/matrix?v3

Lo que habrá que comprobar, cuanto de rápida es, para hacer cálculos...

Objetivo: Re: Gambas 3.3.1
A mi no me pasa eso que comentas....

captura_de_pantalla_de_2012_09_28_19_10_42

Perfil MP  
Objetivo: Re: Gambas 3.3.1
Julio:

Pues a mi tampoco.

¿ Creaste los archivos desde fuentes o bajaste la versión ya compilada ?.

Saludos.

Objetivo: Re: Gambas 3.3.1
No desde un repositorio.... ¿como lo habeis hecho vosotros?

última edición por jsbsan el Sabado, 29 Septiembre 2012, 11:56; editado 1 vez
Objetivo: Re: Gambas 3.3.1
jsbsan escribió:  
No desde un repositorio.... ¿como lo habeis hecho vosotros?


Desde el repositorio.

¿ Se quedara algo de la anterior ?.
No llegue a instalar la 3.3.0.

Estoy usando Ubuntu 11.04 Natty.

Saludos.

última edición por Shell el Sabado, 29 Septiembre 2012, 13:56; editado 1 vez
Objetivo: Re: Gambas 3.3.1
Lo he compilado, y ya no sale el error

...sera que el ppa que estaba usando no esta "actualizado" a la ultima..

Objetivo: Re: Gambas 3.3.1
Yo desde repositorio, yo Ubuntu 12.04 y rep. add-apt-repository ppa:nemh/gambas3

Perfil MP  
Objetivo: Re: Gambas 3.3.1
aratar79 escribió:  
Yo desde repositorio, yo Ubuntu 12.04 y rep. add-apt-repository ppa:nemh/gambas3


Yo también uso ese (en ubuntu 10.04) y va genial, siempre estoy a la ultima. Os lo recomiendo.
Citar:

sudo add-apt-repository ppa:nemh/gambas3;sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 73C62A1B;sudo apt-get update;sudo apt-get install gambas3

Perfil MP  

Página 1 de 1


  
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario

   

Está utilizando la versión (Lo-Fi). Para ver la versión completa del foro, haga clic aquí.

Powered by Icy Phoenix based on phpBB
Design by DiDiDaDo

Página generada en:: 0.0702s (PHP: 1% SQL: 99%)
Consultas SQL: 21 - Debug off - GZIP Activado